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Quick Guide to NM/PT Tumor Analysis in VivoQuant 

All features are available in VQ 1.20 and higher 

I. Open the NM/PT tumor analysis window 

To start the NM/PT tumor analysis tool, go to ToolsAdvanced AnalysisNM /PT Tumor analysis. 

 

If data are currently loaded into VQ, the analysis window will appear immediately; if no data are loaded, 

the DICOM Browser will be opened first and one SPECT or PET data set must be chosen. Only one image 

may be loaded to run the tool. 

 

II. Tumor analysis setup 

a) First, select either Direct Hot Spot or Filter Search: 

 Direct Hot Spot: Information from the test data set and average body data set are used to identify a 

limited search region in which tumor-like clusters of high-activity voxels are identified. 

 Filter Search: Specially designed necrotic and homogeneous tumor filters of varying sizes are used to 

identify image regions most closely corresponding to tumor-like objects. Next to “Filter”, choose 

“homogenous” or “necrotic” according to the type of tumors to be segmented. Or, select “both” to 

try both types of filter. Also choose the filter size according to the size of tumors to be segmented: 

small, medium, large, or all. 
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b) Center Finding Methods. There are several center-finding options that will assist the tumor analysis tool 

in evaluating the ROI. 

 Center: This option provides the tool with a starting point and is good for processing small datasets. 

Position the crosshair manually at the center of the tumor to ensure more accurate tumor 

detection. If you choose to use this option, check “Center” under Center Finding Methods in the 

Settings tab and the coordinates from the crosshair location (and tumor center) will automatically 

be filled in. 

 Body file: An average body file is efficient for batch processing as it refines the region in which the 

tool must search to find the tumor in each subject. This option should only be used when tumor 

positions are consistent across all subjects as it creates an “average” body file representative of all 

subjects in the study. When using a body file, select the box next to “Body file” under Center Finding 

Methods in the Settings tab. Please refer to the iPACS tumor segmentation quick guide for 

instructions on how to generate a body file in VQ. 

 User-provided ROI: The 3D ROI tool can be used to manually draw an ROI. This option is good for 

tumors that may be poorly defined and that the tool is having a difficult time identifying. The 3D ROI 

tool can also be used to make adjustments to an ROI that has been outputted by the tumor analysis 

tool. If a manually constructed tumor ROI is provided, optionally select “Clean ROI” to smooth the 

contour before applying it to the PET or SPECT data. This option can be applied under the 

“Advanced” settings tab. The manually drawn ROI can be recognized by the tool if it is a) located in 
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the output directory and given the name “roi.rmha”, or b) downloaded from the iPACS. NOTE: An 

output directory must be selected before downloading a hand-drawn ROI from the iPACS). 

c) Extraction. Choose one or more extraction methods, which use different algorithms for determining the 

boundaries of the tumor. 

 Auto-Adaptive Thresholding: Multiple threshold values are automatically computed and used in 

combination with image filters and morphological operators to generate the final region of interest. 

 Shape Contouring: Level set methods are applied to a tumor-sized ellipsoid, iteratively deforming 

the ellipsoid contour to generate the final region of interest. 

 Region Growing: A hill-to-valley walking approach is used to detect multiple edges of the tumor.  

Shape filters are applied to these edge points to generate the final region of interest. 

 Spin Ellipse: A rotating contour is applied to the image data across three dimensions.  Morphological 

operators are applied to the average distribution of the contour to generate the final region of 

interest. 

d) General Options. If using images with two animals in the field of view, specify here. 

 Two-Animal Data: Check this option if there are two animals in the image; for single-animal images, 

leave unchecked. 

 Flips: Use these options to specify how the right/anterior animal is oriented with respect to the 

left/posterior animal in terms of flips. L/R is for a left/right flip, A/P is for an anterior/posterior flip, 

H/F is for a head/feet flip. 

 Split Dim: Specify the dimension about which to split the two animals.  Choose “automatic” to 

enable automatic detection, or left/right or anterior/posterior according to the data. 

 Subject: Choose which animal to use for the analysis (left/posterior or right/anterior). 

e) Units. Check the “Convert to uCi” option to generate the results of the tumor analysis in uCi. 

f) Output directory. Specify the output directory for the ROIs generated by the tool. 

III. Use the Advanced tab to specify additional settings. 

a) Quantitation. 

 SUV Type and Value: If an SUV value must be applied to the data being analyzed, enter it here.  The 

SUV Type is ‘Number’ if the image data incorporates the subject’s injected dose and weight 

information; the SUV Type is ‘Cal Factor’ if the images have been reconstructed without taking the 

subject’s injected dose or weight into account. This option is for advanced users and should be done 

in consult with inviCRO. 

 Injected Dose and Weight: If the subject’s injected dose and weight cannot be extracted from the 

iPACS, they can be entered manually here.  
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b) Window. For especially large tumors, the size and extension of the window used to search for the tumor 

region can be extended. 

c) Extraction Parameters. 

 Region Growing Threshold: The default value for this parameter is 0.7 and has a range of 0 to 1. A 

smaller threshold will produce smaller ROIs. 

 Adaptive Threshold: The default value for this parameter is 1, and can range from 0 to Inf. Typically, 

values will fall between 0.7 and 1.2. A smaller threshold will produce larger ROIs. 

 Shape Contour Size: Level set methods are applied to a tumor-sized ellipsoid, iteratively deforming 

the ellipsoid contour to generate the final region of interest. 

d) User-Provided ROI. If a manually constructed tumor ROI is being provided, optionally select “Clean ROI” 

to smooth the contour before applying it to the PT or SPECT data. 

IV. Run the tool. When all desired parameters have been set, click “OK” to begin processing. Progress messages 

will be printed to the window under the “Log” tab. 
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V. View the results. The results of the analysis will be generated in the output directory specified in the 

interface. Upon completion, the segmented tumor(s) will be loaded into the Data List. See the “Desc” field of 

each entry in the data manager to determine the method that was used to generate each output.  

 

 

 

a) The contents of the output directory will include the following: 

 body-img.mhd/raw:  an image file of the subject’s whole body 

 cyl-img.mhd/raw: an image file of a cylinder fit within the subject’s body, placed to avoid hot spots 

at the heart and bladder 

 a tumor-img*.mhd/raw:  image files of the segmented tumors for each generated tumor 

segmentation 
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 a diameterProfile*.csv: a comma-separated table of tumor diameter profiles for each generated 

tumor segmentation 

 a roi-location*.csv: the center of mass of the segmented tumor volume of each generated tumor 

segmentation 

 a suv*.csv: a comma-separated table of relevant tumor uptake statistics for each generated tumor 

segmentation 

 settings.txt: a file that lists the particular settings used to execute the tumor analysis tool; this file 

can be helpful to the inviCRO support staff if it is necessary to debug problems with the tool. 

NOTE: * The number appended to the end of each file corresponds to a particular extraction method.  The 

roi-location.txt can be used as a key for this number. The extraction method is printed inside this file. 

 

IV. Use the 3D ROI Tool to modify a tumor ROI 

a) The 3D ROI Tool maybe used to modify a particular tumor ROI outputted by the NM/PT Tumor 

Analysis Tool. Select the 3D ROI Tool from the drop-down menu. 

 

Load the extracted tumor ROI of interest by clicking on the 3 ½ inch floppy drive symbol with the green 

arrow.  

 

Select the appropriate ‘tumor-roi-*.rmha’ file and edit using the tools available within the 3D ROI. Please 

use the 3D ROI guide within VivoQuant for further reference on the tools available to the user. This ROI 

can be stored on the iPACS by clicking the yellow flower with a green arrow icon.  
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Quick Guide to NM/PT Tumor Analysis on the iPACS 

All features are available in iPACS 1.06 and VQ 1.21 and higher 

 

I. Pre-Process Mouse Hotel Image Data. For single or dual animal image data please go directly to the 

“Generating an Average Body File” section below.  

 

Prepare images for the tumor tool by pre-processing them first in VQ. 

 

a) Convert multi-animal image into individual images for each mouse 

Open image(s) in VQ from a local directory or via the DICOM browser. If opening multiple modalities, 

make sure the images are co-registered to ensure all modalities are included when splitting the image 

into single animal images. If they are not, go to the reorientation tool to manually register the images. 

There will be an opportunity to fine-tune the registrations after the animals are split into separate 

images.  

Navigate to the 3D ROI tool. Navigate to the “Segmentation Algorithms” (magic wand) tab and select 

“Bounding Cylinders” from the drop down menu. 

 

 

 

 

If multiple images are loaded (e.g. CT and PET image), select one image to which the tool will be applied. 

Specify the cylinder radius and click “Apply”. An ROI will be made for each mouse in the hotel. 
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Check that the ROIs completely cover the animals. If part of the animal is not covered by the ROI, the 

user should manually edit the ROI within the 3D ROI tool (sphere tab) or specify a larger cylinder radius 

and reapply the bounding cylinders tool to ensure the ROI will include the entire animal.  

Once satisfied with the ROIs, note which ROI number corresponds with which animal ID. 
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Then go to Tools -> Advanced Analysis -> Split ROI to DICOM.  

 

 

New image files will be loaded into the data manager for each animal with the ROI # in the series 

description.  
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If using multiple modalities, upon clicking “Split ROI to DICOM”, you will be prompted to select which 

modalities you wish to split.  

 

 

 

b) Reorient and Crop each individual image 

Once all individual images are in the data manager, choose one as a reference for matching all other 

images to it. For example, if the hotel contained four animals, reorient all images to the same 

orientation as the animal in the upper left corner of the transverse view. This step is necessary for 

providing an average body file that the tumor tool can use for batch processing. 

 

 

Once all individual images are reoriented to the same area, unload the original data set. Go to the 

Cropping tool located in the Navigation drop down menu. Crop out the extra black space in the images. 

For example, if the hotel contained four animals and the user reoriented all images to the upper left 

corner of the transverse view, the user should crop out the upper right and lower corners.  
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c) Save images to DICOM 

 

Batch save the individual images to the iPACS by going to Tools -> Advanced Analysis -> Preprocessing. 

Check “Store Data” and specify which iPACS repository and which project you wish to save your images. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

12 
NM/PT Tumor Analysis Quick Guide 

II. Generating an Average Body File 

An average body file is efficient for batch processing as it refines the region in which the tool must search to find 

the tumor in each subject. This option should only be used when tumor positions are consistent across all 

subjects as it creates an “average” body file representative of all subjects in the study.  

Open VivoQuant and go to Tools-> Advanced Analysis-> Average Body Calculation 

 

 

 

 

The tool will call the DICOM browser. The user should load between 4-8 representative data sets into the 

average body tool.  
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Right click on the selected image data and select ‘Load into AvgBody’.  The Body Averaging GUI will then load.  

 

 

 Output folder:  Output directory on the local disk storage at which the tool will generate the average 

body file. 

 Dual-Animal Images: select the dual animal check box to activate the dual animal parameters. 

 Split Direction: Can be viewed in VivoQuant by activating the ‘Position Labels ‘ by going to                 

View->Position labels . 

 Flips -> Flips required to reorient animal1 to animal0. 

 Threshold-> Used in the detection of dual-animal images.  It represents the amount of smoothing 

applied to peak-detection curves for identifying locations of the animal(s) in the image.  Default is 

0.18 (should be left at default even for single-animal images). Note: for advanced users. 

 iPACS: Store the average body file on the web disk side of the project tree in the project location 

that the iPACS batch tumor tool will be run from. 

Click ‘Ok’  
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The tool will prompt the user to provide a focused region around the average tumor location via the cropping 

tool. Use the slider bars to execute this task. Click the ‘Ok’ button when satisfied with the selection. If storing the 

average body file to the iPACS, a successful submission window will appear.  
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III. Enter Data Points 

Please use the following data point forms to enter the necessary information associated with each image file 

so the iPACS Tumor PT/NM Analysis Tool and plotting tool run correctly. All forms should be accessed from 

the Browser side of the project-tree in the project of interest. 

 

Project Level Data Points 

Please click on the ‘Add to project’ button on the lower right-hand side of the screen. 

a) img_flips Form (for dual image data only) 

 

 

 

Specify the flips for each animal to be positioned to the orientation of the average body file. Normally, animal 1 

is flipped to the orientation of animal 0, but this is truly dependent upon the orientation of the average body 

file. [A : B : C] input is either a 0 or 1. A: left/right, B: anterior/posterior, C: head feet (up/down). 

Click ‘Submit ‘when finished 
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b) studyunits Form –For Advanced Users 

 

  

 Injected Dose Units: Correlates to the value entered in the Tumor_Analysis form 

 Time Units: Correlates to the value entered in the Tumor_Analysis form 

 Output Units: Desired output units for data.  Please enter the appropriate value in the suvCal field 

which converts non-quantitative data to true quantitative data. A value of 1 should be entered for 

data that was acquired in true quantitative data 
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Image Level Data Points 

Please click on the appropriate form from the Data Points drop-down menu and click on ‘Batch Edit’ button on 

the lower right-hand side of the screen. 

 

 

c) Tumor_analysis(2) Form 

Using form ‘tumor_analysis’ or ‘tumor_analysis2’ depends on whether the data is single or dual animal 

image date respectively. 

 

Mouse 0 refers to the animal in the left, anterior, or head location depending on the split direction of the two 

animals. For instance, if two animals are split left to right, then Mouse 0 would be the animal in the left location 

in the FOV. 

 Time or Day: Acquisition time point of the image 

 Animal ID: Identifier for each animal 

 Group: PI specified group/cohort name 

 Injected Dose: Amount of radioactivity injected into the animal  

 Weight: Weight of the animal during the time of radiotracer injection 

 Tumor Vol (caliper): Approximate tumor volume measured with a caliper instrument 

All fields can be populated via Excel or any spreadsheet reader for batch editing. Simply export the data points 

spreadsheet via the ‘Export Data Points (xls)’ link, update the spreadsheet, and upload by clicking on the ‘Choose 

File’ button followed by clicking on the ‘Re-import XLS’ button.  
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IV. Submitting an ROI Center 

Submitting an ROI center can improve the tool’s performance, whether running locally in VivoQuant or 

in batch mode on the iPACS. Load an image into VivoQuant from the DICOM browser.  

Go to        Tools->Advanced Analysis->Specify ROI Center (2).  

 

Use the cursor to locate the tumor center in the Sagittal, Coronal, and Transverse views. Click on ‘Set’ to 

save the ROI center coordinates for the appropriate animal. 
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Click ‘Ok’ once satisfied with the selections 

V. Running the Tumor PT/NM Analysis Tool 

Log into the iPACS and go to Browser->Process
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Step 1 

Select the Tumor PT/NM Analysis from the drop-down menu and click ‘Select’.  

Step 2  

Select the Project from which data is to be analyzed. Note: The user can filter by the fields seen above.  Click 

‘Submit’ 

Step 3 

Select desired data to be analyzed. Click ‘Next’.  

Step 4 

 

Here the user will find the majority of parameters available to him/her in the GUI when running locally inside 

VivoQuant.  The average-body file needs to be provided if a ROI center or a user-provided ROI associated with 

an image is not provided as a data point.  A user provided ROI can be submitted to the iPACS via the 3D ROI tool 
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in VivoQuant.  For an explanation of the extraction parameters, please refer to the Quick Guide for running the 

NM/PT Tumor Analysis tool in VivoQuant. For two animal data, the user can specify the split direction of the two 

animals or have the tool automatically determine the split. The user also has the option to process one or both 

animals. Click ‘Submit’ when finished. The iPACS will then send the analysis job to the ‘job queue’ for processing. 

The page will automatically update on the bottom of the screen as results are generated. The status of the job 

will be displayed in the upper right-hand portion of the screen.  

 

 

 

VI. Reviewing the Results 

Go to User-> Job Queue to view the status of the job. Right-click on the job and click ‘Select data’. 

 

The next page will contain multiple ROI extractions for each animal analyzed.  
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The user should select the best ‘winning’ tumor or extraction method by checking the ‘select’ checkbox 

located below each image [WebDisk]:  Link to the output results from the tumor tool stored on the webdisk 

side of the project tree. 

 [Restart Job]: Restart job with the same settings as the previous run. This is done usually after an 

ROI center or user-provided ROI via 3D ROI has been provided to the iPACS 

 [Edit Job]: Change the settings for a subsequent run of the tumor tool on this particular data. 

 [Open in VQ/IVS]: Downloads a file, which upon opening, will open VivoQuant and load the 

respective image. 

 [D]: Preview of the ROI quantification data for that particular extraction method. 

 [S]: Sagittal, Coronal, Transverse slices through the center of mass of the ROI.  
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 [T]: Preview additional summary statistics from the extracted ROI. 

For the animals that the user wishes to re-run analysis with a tumor-center provided, please download the 

image of interest and provide a tumor center in VivoQuant. Please see above for providing a tumor center. Once 

a tumor center has been submitted to the iPACS, click on the [Restart Job] link for that animal. Once all ‘winning 

tumors’ have been selected, go to the top right-hand side of the screen and select / name the compilation 

directory appropriately and then click ‘Compile’. (Please see below for when all extraction methods fail for a 

particular animal) 
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For animals that did not have a ‘winner tumor’ selected, only the input image will appear in the compilation 

page.  Open the image in VivoQuant from the [Open in VQ/IVS] link. The user should draw a tumor ROI 

manually via the 3D ROI tool in VivoQuant and submit to the iPACS by clicking on the green arrow flower 

icon,   . The user must restart the job for that particular animal in order to include the manually drawn 

ROI in the analysis. 

If the user wishes to edit an extracted tumor ROI, he or she should select a ‘winning tumor’ to be included in 

the compilation. Open the image in VivoQuant and download this ‘winning tumor’ via the 3D ROI tool by 

clicking on the blue arrow flower icon, . Edit the ROI and re-submit to the iPACS within VivoQuant. The 

user must restart the job for that particular animal in order to include the edited ROI in the analysis.  

 

To re-run analysis, the user can restart the tumor segmentation of a single image by clicking on the [Restart 

Job] link for that particular image on the compilation page or select the multiple images to be re-run from 

the Job Queue page and click ‘restart job’ on the bottom of the page. The tool will bypass the segmentation 

routines when a user-provided tumor ROI has been detected and will move directly to generating the 

summary statistics. 

Once the edited tumor jobs are complete, the user must right click on the parent job again and select ‘Select 

data’. Add the new ‘winning tumors’ to the previous compilation (Make sure to have the same compilation 

folder selected). There will be one given image to select for each tumor that was manually edited. The user 

only has to select given tumors for the jobs that were re-started. The ‘winning tumors’ previously added to 

the compilation page will still be saved on that page. 

The compilation directory on the WebDisk side of the project tree will contain individual folders for each 

animal analyzed and a master spreadsheet. Each individual folder contains the following: 

 Quantitative analysis spreadsheets including tumor profile analysis 

 Image and movie files with embedded tumor ROI 

 Final 3D ROI ‘tumor-roi.rmha’ file 

  

Notes: After a subsequent run, the user will need to refresh the select data screen after it has already 

loaded to view the most recent images.  
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VII. Running the plotting tool 

Once satisfied with the tumor ROIs, click the [Start Plotting] link to activate the plotting tool. This is found on 

the compilation page.  

 

 

A folder, ‘Plotting’ will be generated in the compilation directory containing: 

 All plots (.png and .pdf format)  

 Aggregate pdf report containing all plots 

 Summary Master text fie 

 P-value analysis spreadsheets 

 Plotting tool settings file 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

26 
NM/PT Tumor Analysis Quick Guide 

VIII. Running the study report tool 

After inspecting the plots (images?) for a final QC, the study report should be generated which contains 

imbedded images and movies as well as summary statistics.  

Go to the compilation directory of interest and right click on the StudyReport.tt file and select ‘Edit 

Template’. 
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The user can include information to be displayed in the report in the content window of the editor. If the 

data required a suvCal factor great than 1, then the proper activity units need to be filed in (i.e kBq). Then 

click on the ‘process’  button and a report will be generated within a few moments.  This report will be 

stored in the compilation folder on the WebDisk side of the project.  
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