CT Reconstruction

The CT Reconstruction tool offers a variety of algorithms and filters for generating 3D images from x-ray projection data. Also included is a tool for performing Batch CT jobs.

Getting There

There are multiple ways to reach the CT Reconstruction panel. First, it is available in the Tools Menu

It can also be reached via the DICOM Browser by selecting "Open" when a set of CT Projection data is highlighted and the "Auto-Start Reconstruction" box is checked.

Or, when in the Data Browser, the CT Reconstruction (and Batch CT) programs may be reached my right-clicking on an appropriate data set.

Finally, using the keyboard shortcut "Ctrl+L" will open the Reconstruction panel. For more on keyboard shortcuts in VQ, please see Keyboard Shortcuts.

Function

The CT Reconstruction panel controls the parameters available for generating tailored CT reconstructions.

Reconstruction Parameters

Reconstruction parameters consist of resolution, algorithm, and filter (if filtered back projection (FBP) is selected). Resolution choices include Fast, Standard, and Fine with typical reconstructed voxel sizes ranging from 50-200 μm, depending on the pixel size of the projection data. Algorithm choices include Exact or Fast Cone Beam FBP and available filters include RamLak, SheppLogan, Hamming, Hanning, Cosine, and Blackman. The slider bar below the filter choice allows selection of a filter cutoff frequency.

Study Details, Progress, and Controls

The Study Details panel provides information about the particular study and reconstruction such as patient Name, Object Volume, Voxel Size, Pixel Size, and Memory. The Memory setting provides information on how much memory is needed to reconstruct the volume with the selected settings. Memory values that are too large will be displayed in red. Several options exist for reducing memory usage, including changing reconstruction settings (i.e., use "Fast" instead of "Fine"), disabling the use of normalization (see Settings menu below), using "Fast Cone Beam FBP" instead of "Exact Cone Beam FBP" to reconstruct, reconstructing only a portion of the total volume (see Expert Settings in the Help menu below), or re-acquiring data with smaller projection data (i.e., Fast instead of Ultra-Fine in Nucline).

The exact memory requirements are as such:

AlgorithmBytes per Voxel
Exact cone beam 2*4 per thread
Fast cone beam 4
When using the normalization matrix this adds two more bytes per voxel. This matrix is requires to adjust the sampling for helical acquisition orbits. For circular scans the normalization matrix can be disabled without side-effects.

Typical dimensions and their memory requirements (using matrix normalization):

SetupRequirements
bytes per voxel (bpv) Fast cone beam: 6 bpv
Exact cone beam 1 thread: 10 bpv
Exact cone beam 2 threads: 18 bpv
Mouse, 36x36x60 mm, 200Ám voxels Voxels = 9,720,000
Fast cone beam: 55 MB
Exact cone beam 1 thread: 93 MB
Exact cone beam 2 threads: 167 MB
Mouse, 36x36x37 mm, 100Ám voxels Voxels = 47,952,000
Fast cone beam: 274 MB
Exact cone beam 1 thread: 457 MB
Exact cone beam 2 threads: 823 MB
Mouse, 36x36x20 mm, 50Ám voxels Voxels = 207,360,000
Fast cone beam: 1187 MB
Exact cone beam 1 thread: 1977 MB
Exact cone beam 2 threads: 3560 MB
Rat, 62x62x90 mm, 400Ám voxels Voxels = 5,405,625
Fast cone beam: 31 MB
Exact cone beam 1 thread: 52 MB
Exact cone beam 2 threads: 92 MB
Rat, 62x62x60 mm, 200Ám voxels Voxels = 28,830,000
Fast cone beam: 164 MB
Exact cone beam 1 thread: 275 MB
Exact cone beam 2 threads: 495 MB
Rat, 62x62x20 mm, 100Ám voxels Voxels = 76,880,000
Fast cone beam: 440 MB
Exact cone beam 1 thread: 733 MB
Exact cone beam 2 threads: 1320 MB

The Progress panel gives feedback on the progress of a reconstruction. Before beginning the reconstruction, a plot of the selected filter, including cutoff frequency, is displayed. Once the reconstruction has begun, projection data are displayed as they are used by the reconstruction algorithm. A progress bar indicates the estimated time remaining in the reconstruction.

The Controls panel contains two checkboxes and the Start button. The Start button begins the reconstruction. As the reconstruction is running, it can also be used to stop the reconstruction. The first checkbox, "autostart", will automatically begin a reconstruction when the CT panel is called from the Data Browser. The second checkbox, "autosave", will automatically save a reconstruction once completed.

Preview and Color Panel

The Preview panel displays the CT reconstruction as it is being calculated. The Color Panel provides several color map options.

File Menu

Option Description
Load DICOM Data... Identical to the function of "Ctrl+D", this option opens the Data Browser window from where a set of CT projection data may be loaded. Note that the Browser opens with the "CT Projection" data filter set.
Load Local Data... Identical to the function of "Ctrl+L", this option opens a Windows Explorer browser window. A properly chosen CT projection data set is then loaded into the CT Reconstruction tool.
Save... Allows the user to save the data in DICOM format both into the selected repository and a local folder.
Transfer to VQ The reconstruction is opened in the VQ. If the reconstruction is allowed to finish, this transfer occurs automatically.

Settings Menu

Option Description
Save Settings Saves the current CT Reconstruction Settings
Hounsfield... The Hounsfield Calibration uses the linear response of the detector at each of the x-ray operating voltage to calculate dose to an object in terms of Hounsfield units. For more information, please see Hounsfield Calibration.
Threads Allows user to enable multiple threads (1, 2, 3, 4, 6, or 8) for performing the CT Reconstruction. Note that it only makes sense to enable as many threads as there are cores available in the computer's processor.
Thread Priority Defines the priority given to the CT Reconstruction with respect to other tasks being performed by the CPU.
Advanced Allows the user to disable the use of normalization in the reconstruction. Disabling normalization prevents the use of Hounsfield Calibration, but reduces the memory usage required for the reconstruction.
Auto Bed Removal For users imaging with the Minerve bed system, this option will automatically remove the Minerve bed from the CT during reconstruction.

Help Menu

The primary feature of the Help Menu is the Expert Settings panel. This panel is only for advanced users and allows several key parameters in the CT reconstruction to be overwritten, including voxel size, voxel volume (both axially and transaxially), Z offset, sampling, threads, and Up scaling.

Option Description
Voxel Size Allows the user to choose a voxel size in either the X/Y (transverse) or Z (axial) directions that differs from the 3 options (Fast, Standard, Fine) offered in the main CT Reconstruction panel. NOTE: Changing the voxel size may slightly alter the voxel volume.
Voxel Volume Allows the user to modify the reconstructed volume either in terms of voxel number or total reconstructed size (in mm). Modifications may be made in either the X/Y (transverse) or Z (axial) directions.
Z offset (disabled) Allows the user to shift and restrict the reconstructed volume to better center features of interest, enabling more reasonable resolution times for high-resolution images.
Sampling Sets the number of rays used by the Exact Cone Beam Algorithm during the reconstruction.
Threads Sets the number of threads used during reconstruction. The optimal value is determined by the number of cores or processors in that particular machine's CPU.
Up scaling Up scaling may be used to reduce an image size by a factor 2^N. Smaller image sizes are often more manageable.

BatchCT Tool

The BatchCT tool is a useful application which enables the user to select a number of X-ray projection data studies and order them for reconstruction at a later stage. The CT scans are saved in an appropriate batch file and can be left to reconstruct automatically. The parameter settings and file names can be predefined.

The BatchCT tool is reached via the Data Browser by right clicking on the CT scan of interest and selecting "send to BatchCT".

The BatchCT reconstruction panel is then displayed. This panel provides options for Reconstruction Parameters, Study Details and Repository. The user can define which reconstruction parameters to use (see CT reconstruction above) and can enter details about the study. It is important to label the Study Description box in the Study Details section because this will be the name assigned to the reconstructed data. The repository location is also displayed. To continue with the batching function press OK.

Once the X-ray projection data has been sent to BatchCT, the BatchCT window can be opened by clicking the small white BatchCT icon on the bottom right hand corner of the screen. This window displays all the projection data previously sent for batching and contains various functions to control the process.

The BatchCT window is divided into 3 main sections; Job List, Status and Log File. There are icons along the left side of the window for manipulating the batching process.

Job List

The job list provides a list of the X-ray projection data to be reconstructed. Information about each individual scan is divided into a number of sections.

Option Description
Mod Provides information on the modality used i.e. CT.
Details Displays the batch number ID, the number of projections used and the name of the reconstruction as it will appear when loaded into VQ.
Patient This is the name of the folder from which the X-ray projection data was taken.
Parameter
Status Provides information on the status of the reconstruction. If the status is Running then the reconstruction is underway, if it is Waiting then the reconstruction has yet to begin. The status section will also indicate when it is storing a completed reconstruction and when it is about to start a new reconstruction.

Status

The status of the current reconstruction job along with the total number of scans to be reconstructed is displayed in the Status bar and indicates the percentage of data remaining to be reconstructed.

Log file

File Menu

The file menu in the main window offers the following functions in the BatchCT application.

Option Description
Hide Hides the Batch CT window from the desktop. Also reached using the Ctrl+H keyboard shortcut.
Quit Quits the Batch CT application. Also reached using the Ctrl+Q keyboard shortcut.
Stop Service Stops the Batch CT application. Also reached using the Ctrl+T keyboard shortcut.
Start Service Starts the Batch CT application.

Jobs Menu

The batch file can be altered using the icons to the left of the window or via the Jobs menu in the main window.

The job icons are located on the left side of the window.

Option Description
Pause Pauses the current reconstruction job.
StopJob Stops the reconstruction job.
MoveUp Moves the selected projection data up the list of studies to be reconstructed.
MoveDown Moves the selected projection data down the list of studies to be reconstructed.
EditJob Allows you to edit the reconstruction parameters.
DeleteJob Deletes the projection data from the reconstruction list.

These functions can also be accessed under the Jobs menu in the main window. Additional functions available here include Thread Number, Thread Priority and Show Bubbles.

Option Description
Thread Number Sets the number of threads used during reconstruction.
Thread Priority The BatchCT tool may be given different priority levels. Lower priority means that the tool will run only when the computer is completely idle. A higher priority means that the tool will continue to run even when other processes are occurring.
Show bubbles Information bubbles pop up in the task bar as jobs are added, completed, etc. This switch controls whether or not these bubbles appear.