HiSPECT

HiSPECT is an external software package used to perform reconstructions on NanoSPECT/CT SPECT data. The HiSPECT options are best reached from within the Tools Menu of the VQ. In addition to a "Reconstruction" option, there are other HiSPECT database tools such as Batch Mode, Quantification Tables, and a PSF Manager. In addition, there are data manipulation tools such as EKG Split, Save Calibration.txt, Sum Projections (Experimental), and Append Projections (Experimental). An additional tool, the BatchTool Generator, may be used to streamline the creation of batch mode files used by the HiSPECT Batch Tool.

Getting There

There are two methods to reach the HiSPECT reconstruction software from within the VQ and a third method using a shortcut on the Desktop. The first method is via the Data Browser by selecting "Open" when a set of SPECT Projection data is highlighted and the "Auto-Start Reconstruction" box is checked. The data set is then automatically loaded and ready to run.

The HiSPECT reconstruction can also be reached for use with local DICOM files by selecting "Reconstruction" from the choices in the HiSPECT section of the Tools Menu. This option allows the user to choose a DICOM file from a local directory (as opposed to the DICOM server).

The HiSPECT may also be reached using the HiSPECT shortcut on the Desktop.

After opening the HiSPECT reconstruction using either of these second two methods, it is necessary to load data from a local DICOM file. Begin by selecting "Choose Projection Data",

Next select "Local DICOM file" and hit OK.

Navigate to the appropriate local directory and select the set of SPECT data that you would like to reconstruct.

Hit OK to load the data for reconstruction.

Function

HiSPECT Reconstruction

Whenever SPECT projection data is opened for reconstruction with VivoQuant, the HiSPECT reconstruction front panel appears. This panel contains important information pertaining to the data set and also displays the SPECT projection data both slice-by-slice and as a movie.

Information pertinent to the data set is found on the following panel:

Field Information
Name (ID) Patient Name / Study Identifier
Study (ID) Full Protocol Name
Series Description Protocol Step
Acquisition Date Acquisition Date
Nucline Isotope used in acquisition
Acquisition Time Acquisition Time
Aperture Set Aperture used during acquisition -- may be selected manually
Flood Table Date of flood measurement to be used -- may be selected manually
Geometric Calibration Date of calibration data to be used -- may be selected manually
Detector Selection List of detectors to be used in reconstruction -- may be selected manually

This screen also provides options for controlling the movie of the projection data, saving a movie of the projection data, and changing or inverting the color display of the projection data.

After confirming that all information is correct, Next Step should be pushed to continue to the next screen.

The second HiSPECT screen contains reconstruction options, including Noise Suppression, Voxel Size, and Reconstruction Settings. Three choices are presented for each setting. The degree of noise suppression determines how much smoothing is applied during the reconstruction, with lower meaning less smoothing. Voxels are small cubes that fill up the reconstructed object space and the choices here represent the length of a side of the cube. Reconstruction settings refers to the number of iterations performed during the reconstruction with fast meaning fewer iterations and fine meaning more iterations.

Noise suppression refers to how much smoothing is applied during the reconstruction. For data sets with good statistics (i.e., many counts per projection), low noise suppression may be used. Lowering the noise suppression can improve the final resolution but also produces more artifacts if there are not sufficient counts. Increasing the noise suppression leads to smoother, more artifact-free images but at the potential cost of resolution. Shown below are reconstructions of a Jaszczak phantom using different reconstruction settings. The data were acquired with excellent statistics, enabling successful use of low noise suppression.

Reconstruction
Low, Fast, Fast
Low, Fine, Fine
Middle, Standard, Standard
High, Fast, Fast
High, Fine, Fine
Image Slice

After selecting the desired reconstruction settings, press Start to begin the reconstruction or "Add to batch job" to add the reconstruction to a new or pre-existing batch file. See Batch Mode for more details. Once the reconstruction is started, the progress bar may be used to tell how much time remains before the reconstruction finishes.

As the reconstruction is running, further progress is shown in the panel below the progress bar. The panel informs the user when the reconstruction has finished. At this point, it is time to click Next Step to view the reconstruction as a MIP and save the final product.

The final screen displays a MIP of the reconstruction, as well as the option to save the reconstruction.

When "Save Reconstruction" is clicked, a final window appears that allows the user to name the reconstruction as they would like it to appear in the DICOM browser.

Batch Mode Reconstruction

The HiSPECT batch tool is a useful program which enables the user to select a number of SPECT scans and order them for reconstruction at a later stage. The SPECT scans are saved in an appropriate batch file and can be left to reconstruct automatically. The parameter settings and file names can be predefined. An additional tool, the BatchTool Generator, may be used to streamline the creation of batch mode files used by the HiSPECT Batch Tool.

Getting There

There are three methods to begin the process of adding a data set to a batch file from within the VQ. The first method is to select "Batch Tool" from the choices in the HiSPECT section of the Tools Menu.

The second method is via the Data Browser by right clicking on the appropriate set of SPECT Projection data and selecting "send to HiSPECT". A browser window is subsequently displayed in which a batch file can be created. All SPECT projection data from a particular study to be batched can be saved in this file.

The third method is to use the BatchTool Generator..

Creating a Batch Job

The initial HiSPECT reconstruction window is displayed with the selected SPECT projection data loaded. The user can define reconstruction parameters by following the reconstruction protocol described above. Once the desired parameters have been chosen, the process is initiated by clicking the "Add to Batch" button.

The user is then prompted to choose a Batch file. For the first reconstruction in the batch, it is recommended that a new Batch file be created. When adding more reconstructions, select this newly created Batch file.

Once a Batch file has been selected, the "Complete Batch" button should be selected.

This selection introduces a window where the user can suitably label the reconstruction to complete the process.

If data has been chosen for addition to a Batch job from the DICOM browser, the procedure is done. However, if data from a local file has been chosen, then one more step is required to name the data as it will appear in the local folder.

This procedure is followed for each set of SPECT projection data to be reconstructed. At the completion of each added set, a congratulatory message is displayed.

Running a Batch Job

There are two methods to open the Batch Tool. First, the Batch Tool may be loaded from within the VQ under Tools | HiSPECT.

The Batch Tool may also be opened via the Batch Tool shortcut found on the Desktop.

Once the Batch Tool is open, a batch file can be loaded by either clicking on the Load Batch thumbnail in the main window or via Load Batch under the File menu.

Once the file is loaded, the SPECT projections to be reconstructed are displayed in Task List Box. The Control Panel is used to control the running of the batch job. To initiate the reconstructions, the Start button is selected. The reconstructions can be paused or stopped at any stage during the batch job and any unreconstructed data can be saved.

The progress of the reconstructions is displayed in real time. Also, the Batch Tool makes used of multiple cores to speed the reconstruction process.

PSF Manager

The PSF Manager is used as a reference for and to calculate Mothertables used during reconstruction. For each aperture and isotope combination, a one-time calculation taking 12-15 minutes must be performed prior to reconstruction. These tables may be pre-computed using the PSF Manager. The PSF Manager may be found in the Tools | HiSPECT menu.

When the PSF Manager is opened, a table appears displaying all isotopes and apertures for which that NanoSPECT is equipped. Pre-computed tables are shown with green check marks.

To select a combination or set of combinations to be computed, simply click on the appropriate field in the table.

Perform a ctrl-click to select multiple entries or click and drag to select a block of entries or select an entire column to compute at once or an entire row. Any set of aperture and isotope combinations may be pre-computed at any given time. Once the desired selections have been made, hit "Compute" to begin the calculations.

Once the computations are finished, the field in the table will be replaced by a green checkmark and a date to indicate when the calculation was performed.

Quantification Tables

The Quantification Table lists all quantification factors currently present in VQ. The Quantification Table can be reached in Tools | HiSPECT.

Quantification factors are used to produce physically meaningful voxel values (i.e., voxels in units of kBq) in SPECT measurements. For more on setting Quantification Factors for the NanoSPECT/CT, please see this guide.

ECG Split

Required Software: Nucline Build 46 (or higher), VQ Version 1.33 (or higher), HiSPECT 1.2.5.111 (or higher)

Processing Steps

Save Calibration.txt

Save Calibration.txt extracts the pinhole-specific calibration data information from a NanoSPECT-generated SPECT data set. This data may be manually entered into HiSPECT and used to reconstruct other SPECT data sets.

Sum Projections EXPERIMENTAL!

This tool may be used to sum projection data from multiple SPECT acquisitions. The advantage of summing data from multiple acquisitions is an improvement in statistics, which in turn leads to better noise properties and higher resolution in the reconstructed data set. Data may only be summed if they are acquired with identical acquisition parameters, including scan range, number of projections, acquisition time, and start angle.

To use the tool, go to Tools | HiSPECT | Sum Projections. When this tool is selected, the Data Browser opens. Select the data sets that you would like to sum (using the Ctrl key).

After selecting the data sets, click on "Open" and a dialog box will open enabling you to name the summed data set and store it in the repository of your choosing.

See below three individual projection data sets with a sum projection below. Proper scaling has been used to make the images color comparable.

Projection data from single acquisitions

 

Projection data from the sum of the acquisitions

See below the reconstructions from an individual data set and from the summed data set. Proper scaling has been used to make the images color comparable.

Reconstruction of a single acquisition

 

Reconstruction with summed projections

Append Projections EXPERIMENTAL!

This tool may be used to append projection data from multiple data sets. For example, if two data sets are acquired with overlapping scan ranges, these data sets may be appended to one another to form one large data set. This single data set will then reconstruct into a single large reconstruction.

To use the tool, go to Tools | HiSPECT | Sum Projections. When this tool is selected, the Data Browser opens. Select the data sets that you would like to sum (using the Ctrl key).

After selecting the data sets, click on "Open" and a dialog box will open enabling you to name the summed data set and store it in the repository of your choosing.

After appending the projections, reconstruct the data as described in HiSPECT Reconstruction.